PocketWizard Utility 1.54 & 1.55 Released

From PocketWizard:
 
Utility 1.54 & 1.55 offers compatibility with PocketWizard Plus III
 
November 9, 2012 – PocketWizard, the industry leader in wireless control and synchronization of cameras, flash and light meters, announces today the release of Utility version 1.54 & 1.55. Utility version 1.54 & 1.55 offers a few new features from Utility 1.35 including the ability to upgrade your PocketWizard Plus III with future firmware updates.
 
Utility 1.54 & 1.55 offer many improvements including improved help text, automatic notifications for new firmware and the addition of a scrollbar to the inner frame allowing for better full screen operations on smaller displays. Additionally, a final version for PowerPC-based Macs running Mac OS X version 10.5 “Leopard” was created.
 
Utility 1.54 & 1.55 is compatible with all USB enabled PocketWizard radios including MiniTT1 and FlexTT5 for both Canon and Nikon, Plus III, PowerST4, PowerMC2 and MultiMAX (USB enabled only). PocketWizard Utility 1.55 is for Windows and Intel Mac operating systems. 1.54 is for PowerPC* MAC operating systems.
* Version 1.54 for PowerPC is the final PocketWizard Utility for PowerPC-based Macs. There will be no future PocketWizard Utility versions for PowerPC-based Macs.
 
Click here to download PocketWizard Utility 1.54 or 1.55
 
See the full release notes here.
Posted: 11/10/2012 8:54:50 AM CT   Posted By: Sean
comments powered by Disqus
Help  |  © 2003-2014 The Digital Picture, LLC  |  Bryan CarnathanPowered By Christ!