PocketWizard Issues MiniTT1 and FlexTT5 EOS 5D Mark III Compatibility Status Update

From PocketWizard:
 
Status of 5D Mark III Compatibility with MiniTT1 and FlexTT5
 
So. Burlington, VT – August 27, 2012 - We have a version of the ControlTL firmware that includes compatibility for the 5D Mark III that is very promising. We are hard at work testing it with both the 5D Mark III and all the other previously compatible Canon cameras, flashes, and transmitters. Please keep in mind, the beta and the official release must be compatible with all currently supported cameras in addition to the 5D Mark III - we cannot separate one version out for just one particular camera.
 
Testing is going well and we are making progress every day. That being said a bug could pop up at any given moment and delay the release of the firmware. To complete our testing as quickly as possible we have dropped all other tasks in our support office to get this testing done. This means we’re not answering the phone, not responding to emails and not answering questions on Facebook for a few days. Although we are hopeful to have a release within the next couple of weeks, we cannot give any definite date on when this firmware will be available.
 
We are just as eager to provide full support for the 5D Mark III as you are to employ it in your photography. We recognize the popularity and importance of this camera and we fully appreciate the impact that this has on your workflow. Our goal is to deliver firmware that you will have confidence in.
Posted: 8/27/2012 5:11:57 PM CT   Posted By: Bryan
Posted to: Canon News
comments powered by Disqus
Help  |  © 2003-2014 The Digital Picture, LLC  |  Bryan CarnathanPowered By Christ!