PocketWizard Announces TTL Compatibility with the Nikon D810, Canon 70D and Others

PocketWizard Logo
From PocketWizard:
 
Latest TTL firmware update expands extensive list of compatible cameras making PocketWizard more in sync with what today’s photographers are shooting with.
 
So. Burlington, VT – August 5, 2014 - LPA Design, manufacturers of PocketWizard Photo Products, the world leader in wireless control of cameras, flash lighting and flash power control with Sekonic light meters, announces today a new update to its ControlTL firmware for both Nikon and Canon versions of its MiniTT1 and FlexTT5 radios. Firmware version 3.700 for Nikon includes compatibility with the recently released D810, D610, D4S and other Nikon cameras. Additionally, firmware version 6.700 for Canon now provides TTL compatibility with the Canon 1D X, 6D and T4i as well as other recently released Canon cameras. See the compatibility list below. Any current owner of the ControlTL system can easily install this version via USB and update for free using the PocketWizard Utility. PocketWizard Utility version 1.54 or later is required before installing this update.
 
“Not only are we now compatible with all current Canon and Nikon DSLRs, we’ve added resources to our firmware department allowing us to have a significant breakthrough in firmware development. We can react much more quickly to newer cameras entering the market,” said Heather Ambrose, Marketing Director at LPA Design, the company that manufacturers PocketWizard Photo Products. “We received a Nikon D810 two weeks ago and our firmware engineers got right on it. A focused look under the hood and they found that the camera behaved similar to the D4S. After a few iterations of firmware, combined with comprehensive testing, it was determined that the D810 could be added to the current firmware release. This is by far the fastest turnaround we’ve been able to achieve, and we hope to keep this momentum going.”
 
For more information on how to update PocketWizard products via USB connection and to view current release notes for Nikon firmware update version 3.7 and Canon firmware version 6.7 please click here.
 
The MiniTT1 and FlexTT5 are now fully compatible with the following recently released Canon and Nikon DSLRs:
 
Canon Cameras

  • 70D
  • 1D X*
  • 6D*
  • T5i / 700D
  • T4i* / 650D
  • T5 / 1200D
  • SL1 / 100D

Nikon Cameras

  • D810
  • D610
  • D4S
  • Df
  • D7100
  • D5300
  • D5200
  • D3300

* Now with TTL compatibility.
 
For a complete compatibility list, please visit:
Canon Compatibility | Nikon Compatibility
 
B&H carries the Pocketwizard MiniTT1 and FlexTT5 radio triggers.

Posted: 8/5/2014 10:02:45 AM CT   Posted By: Sean
comments powered by Disqus
Help  |  © 2003-2014 The Digital Picture, LLC  |  Bryan CarnathanPowered By Christ!